Skip to main content

Write a C program to find number is Abundant number or not

 

Write a C program to find the number is an Abundant number or not:-




In this program to find a number is an Abundant number or not. A number n is said to be an Abundant Number to follow these condition

  • the sum of its proper di


    visors is greater than the number itself.
  • And the difference between these two values is called abundance.

Ex:- Abundant number  12 having a proper divisor is 1,2,3,4,6 the sum of these factors is 16 it is greater than 12 so it is an Abundant number.

Some other abundant numbers

    18, 20, 24, 30, 36, 66, 70, 72, 78, 80, 84, 88, 90, 96, 100, 102, 104, 108, 112, 114, 120..

ALGORITHMS:-

Step 1- Enter the number, to find the Abundant number.
Step 2- Initialize the loop with c=1 to c<=number and follow the following calculation
     (i) check if whether the number is divisible with c and c got a result zero.
     (ii) now sum=sum+c, add a digit into a sum and store it in the sum.

Step 3. then the checksum is greater than the number print true.

Step 4. else it is not an abundant number
Step 5- Stop.

 Code:-

#include<stdio.h>
int main()
{
      //initialization variables
       int number,sum=0,c;
     //input from user
     printf("Enter a number : "); 
      scanf("%d",&number);
    //declare a variable to store sum of factors of the number
     for(c = 1 ; c < number ; c++)
     {
           if(number % c == 0)
              //sum+=c;
               sum = sum + c;
     }
     if(sum > number)
          //display the result
           printf("Abundant Number");
     else
       //display  
         printf("Not an Abundant Number");

    return 0;
}
























OUTPUT:










 FOLLOW AND SUBSCRIBE THIS WEBPAGE FOR 
 MORE NEW PROGRAMS AND CODING SOLUTIONS.






























Comments

Popular posts from this blog

HackerRank Tuples Solution in Python

  HackerRank Tuples Solution in Python Task Given an integer,n, and n  space-separated integers as input, create a tuple, t, of those n integers. Then compute and print the result of hash(t). Note:   hash()  is one of the functions in the  __builtins__  module, so it need not be imported. Input Format The first line contains an integer,n, denoting the number of elements in the tuple. The second line contains n space-separated integers describing the elements in tuple t . Output Format Print the result of  hash(t) . Sample Input 0 2 1 2 Sample OUTPUT- 3713081631934410656 n = int(input()) int_list = [int(i) for i in input().split()] int_tuple = tuple(int_list) print(hash(int_tuple))

How to check if the given number is Even or odd-

1. How to check if the given number is Even or odd- We can determine whether a number is even or odd. This can be tested using different methods. The test can be done using simple methods such as testing the number’s divisibility by 2. If the remainder is zero, the number is even. If the remainder is not zero, then the number is odd. The following algorithm describes how a C program can test if a number is even or odd. CODE:- #include <stdio.h> int   main () { int num;//variable declaration printf("Enter any num: ");// take input from user  scanf("%d",&num);// declare input if(num%2==0) { printf("The num %d is even",num); } else { printf("The num %d is odd",num); } return 0; }     ALGORITHM:- Step 1.   Start Step 2 .   Enter a number. Step 3.   If...

Binary to Decimal conversion program

  3. Binary to Decimal conversion program using C language:- The C program converts binary number to decimal number that is equivalent. A decimal number can be attained by multiplying every digit of binary digit with a power of 2 and totaling each multiplication outcome. The power of the integer starts from 0 and counts to n-1 where n is assumed as the overall number of integers in a binary number. Ex:-   ( 101100001 ) 2 =( 353 )10                                                  ALGORITHMS:- Step 1:  Start Step 3:  The user is asked to enter a binary number as an input Step 4:  Store the quotient and remainder of the binary number in the variable rem Step 5:  Multiply every digit of the entered binary number beginning from the last with the powers of 2 correspondingly Step 6:  Repeat the above step...