Skip to main content

Program to find Smallest element in an array using C

 

Program to find Smallest element in an array using C

We will find the smallest or minimum element in an array using the C concept. We apply an algorithm that assumes the first element as the smallest element and then compares it with other elements if an element is smaller than it then, it becomes the new smallest element, and this process is repeated till the complete array is scanned.



ALGORITHMS:- 

STEP 1:-  Initialize the required variables.
STEP 2:-  Take the input from the user.
STEP 3:-  Assume the smallest element is present at the first position.
STEP 4:-  Scan each element with the help of for a loop.
STEP 5: Check if the element Scanned is new smaller than small.
STEP 6:-  If it is smallest than small, change the value of small.
STEP 7:-  Print small as it stores the smallest element of the array.


CODE:-

#include<stdio.h>
int main()
{
    int a[50],p,num,smallest;
    printf("Enter the value of num: ");
    scanf("%d",&num);
    printf("Enter the element of array:");

    for(p=0; p<num; p++)
    {
      scanf("%d",&a[p]);
    }
    smallest= a[0];

    for(p=0; p<num; p++)
    {  
        if(a[p]<smallest)// Check condition
        {
        smallest=a[p]; //replace the value of a[p]
        }
    }
    printf("The smallest element is %d ", smallest); 
    return 0;
}


OUTPUT:-


FOLLOW THIS WEBPAGE FOR MORE NEW PROGRAMS AND CODING SOLUTIONS. 

Comments

Popular posts from this blog

HackerRank Tuples Solution in Python

  HackerRank Tuples Solution in Python Task Given an integer,n, and n  space-separated integers as input, create a tuple, t, of those n integers. Then compute and print the result of hash(t). Note:   hash()  is one of the functions in the  __builtins__  module, so it need not be imported. Input Format The first line contains an integer,n, denoting the number of elements in the tuple. The second line contains n space-separated integers describing the elements in tuple t . Output Format Print the result of  hash(t) . Sample Input 0 2 1 2 Sample OUTPUT- 3713081631934410656 n = int(input()) int_list = [int(i) for i in input().split()] int_tuple = tuple(int_list) print(hash(int_tuple))

How to check if the given number is Even or odd-

1. How to check if the given number is Even or odd- We can determine whether a number is even or odd. This can be tested using different methods. The test can be done using simple methods such as testing the number’s divisibility by 2. If the remainder is zero, the number is even. If the remainder is not zero, then the number is odd. The following algorithm describes how a C program can test if a number is even or odd. CODE:- #include <stdio.h> int   main () { int num;//variable declaration printf("Enter any num: ");// take input from user  scanf("%d",&num);// declare input if(num%2==0) { printf("The num %d is even",num); } else { printf("The num %d is odd",num); } return 0; }     ALGORITHM:- Step 1.   Start Step 2 .   Enter a number. Step 3.   If the number is divisible by 2, it is even. Step 4 .   If the number is not divisible by 2, it is odd. Step 5.  Stop EXAMP

Binary to Decimal conversion program

  3. Binary to Decimal conversion program using C language:- The C program converts binary number to decimal number that is equivalent. A decimal number can be attained by multiplying every digit of binary digit with a power of 2 and totaling each multiplication outcome. The power of the integer starts from 0 and counts to n-1 where n is assumed as the overall number of integers in a binary number. Ex:-   ( 101100001 ) 2 =( 353 )10                                                  ALGORITHMS:- Step 1:  Start Step 3:  The user is asked to enter a binary number as an input Step 4:  Store the quotient and remainder of the binary number in the variable rem Step 5:  Multiply every digit of the entered binary number beginning from the last with the powers of 2 correspondingly Step 6:  Repeat the above steps with the quotient obtained until the quotient becomes 0 Step 7:  The sum of the numbers will give the decimal number as a result, print the decimal value. Step 8:   Stop. CODE:-   #includ