Skip to main content

How to find a reverse of a given number in c programming

 How to find reverse of a given number in c programming:- 

This program reverses a number entered by a user and then prints it. For example, if a user will enter 6577756 as input then 6577756 will be printed as output.
This C program accepts an integer and reverses it.
 



ALGORITHMS:-

Step 1. Take the number which you have to reverse as the input variable says the number.

Step 2. Obtain its quotient and remainder.

Step 3. Multiply the separate variable with 10 and add the obtained remainder to it.

Step 4. Do step 2 again for the quotient and step 3 for the remainder obtained in step 4.

Step 5. Repeat the process until the quotient becomes zero.

Step 6. When it becomes zero, print the output and exit.

Step 7. Stop.

CODE: -

#include<stdio.h>
int main()
{
    int num,rev=0,rem;
    printf("Enter any number: ");
    scanf("%d",&num);
    while(num>0)
    {
      rem= num%10;
      rev= rev*10+rem;
      num=num/10;
    }  
    printf("The reverse num is %d",rev);
    return 0;
    
}



OUTPUT:-



FOLLOW THIS WEBPAGE FOR MORE NEW PROGRAMS AND CODING SOLUTIONS.



Comments

Popular posts from this blog

HackerRank Tuples Solution in Python

  HackerRank Tuples Solution in Python Task Given an integer,n, and n  space-separated integers as input, create a tuple, t, of those n integers. Then compute and print the result of hash(t). Note:   hash()  is one of the functions in the  __builtins__  module, so it need not be imported. Input Format The first line contains an integer,n, denoting the number of elements in the tuple. The second line contains n space-separated integers describing the elements in tuple t . Output Format Print the result of  hash(t) . Sample Input 0 2 1 2 Sample OUTPUT- 3713081631934410656 n = int(input()) int_list = [int(i) for i in input().split()] int_tuple = tuple(int_list) print(hash(int_tuple))

How to check if the given number is Even or odd-

1. How to check if the given number is Even or odd- We can determine whether a number is even or odd. This can be tested using different methods. The test can be done using simple methods such as testing the number’s divisibility by 2. If the remainder is zero, the number is even. If the remainder is not zero, then the number is odd. The following algorithm describes how a C program can test if a number is even or odd. CODE:- #include <stdio.h> int   main () { int num;//variable declaration printf("Enter any num: ");// take input from user  scanf("%d",&num);// declare input if(num%2==0) { printf("The num %d is even",num); } else { printf("The num %d is odd",num); } return 0; }     ALGORITHM:- Step 1.   Start Step 2 .   Enter a number. Step 3.   If...

Binary to Decimal conversion program

  3. Binary to Decimal conversion program using C language:- The C program converts binary number to decimal number that is equivalent. A decimal number can be attained by multiplying every digit of binary digit with a power of 2 and totaling each multiplication outcome. The power of the integer starts from 0 and counts to n-1 where n is assumed as the overall number of integers in a binary number. Ex:-   ( 101100001 ) 2 =( 353 )10                                                  ALGORITHMS:- Step 1:  Start Step 3:  The user is asked to enter a binary number as an input Step 4:  Store the quotient and remainder of the binary number in the variable rem Step 5:  Multiply every digit of the entered binary number beginning from the last with the powers of 2 correspondingly Step 6:  Repeat the above step...