Skip to main content

How to find Number is a positive or Negative in C

How  to find  Number is a positive or Negative in C:-

  • The following concept will test whether a number is positive or negative. It is done by checking where the number lies on the number line. The following algorithm will help to check this condition.

  • If the input number is greater than zero then it is a positive number.
  • If the input number is less than zero it is a negative number.
  • If the number is zero then it is neither positive nor negative.

  • Same logic we have followed in the below C program.

ALGORITHMS:-

  • Step 1. Start
  • Step 2. Enter the number.
  • Step 3. If the number is less than or equal to zero, check if it is zero.
  • Step 4. If the number is zero, print, “, The number is zero.”
  • Step 5. If the number is less than zero, print, “The number is negative.”
  • Step 6. If the number is more than zero, print, “The number is positive.”
  • Step 7. Stop

 Code:-

#include<stdio.h> 
int main()
{
    int num;
    printf("Enter the value of num: ");
    scanf("%d",&num);
//take input from user
    if(num>0)
//for positive number
    {
        printf("The num %d is positive",num);
    }else if (num<0)
    {
        printf("The num %d is negative",num);
    }else{
        printf("The num %d is equal to zero",num);
    }
    return 0;



























OUTPUT:






 FOLLOW AND SUBSCRIBE THIS WEBPAGE FOR 
 MORE NEW PROGRAMS AND CODING SOLUTIONS.

Comments

Popular posts from this blog

HackerRank Tuples Solution in Python

  HackerRank Tuples Solution in Python Task Given an integer,n, and n  space-separated integers as input, create a tuple, t, of those n integers. Then compute and print the result of hash(t). Note:   hash()  is one of the functions in the  __builtins__  module, so it need not be imported. Input Format The first line contains an integer,n, denoting the number of elements in the tuple. The second line contains n space-separated integers describing the elements in tuple t . Output Format Print the result of  hash(t) . Sample Input 0 2 1 2 Sample OUTPUT- 3713081631934410656 n = int(input()) int_list = [int(i) for i in input().split()] int_tuple = tuple(int_list) print(hash(int_tuple))

How to check if the given number is Even or odd-

1. How to check if the given number is Even or odd- We can determine whether a number is even or odd. This can be tested using different methods. The test can be done using simple methods such as testing the number’s divisibility by 2. If the remainder is zero, the number is even. If the remainder is not zero, then the number is odd. The following algorithm describes how a C program can test if a number is even or odd. CODE:- #include <stdio.h> int   main () { int num;//variable declaration printf("Enter any num: ");// take input from user  scanf("%d",&num);// declare input if(num%2==0) { printf("The num %d is even",num); } else { printf("The num %d is odd",num); } return 0; }     ALGORITHM:- Step 1.   Start Step 2 .   Enter a number. Step 3.   If...

Binary to Decimal conversion program

  3. Binary to Decimal conversion program using C language:- The C program converts binary number to decimal number that is equivalent. A decimal number can be attained by multiplying every digit of binary digit with a power of 2 and totaling each multiplication outcome. The power of the integer starts from 0 and counts to n-1 where n is assumed as the overall number of integers in a binary number. Ex:-   ( 101100001 ) 2 =( 353 )10                                                  ALGORITHMS:- Step 1:  Start Step 3:  The user is asked to enter a binary number as an input Step 4:  Store the quotient and remainder of the binary number in the variable rem Step 5:  Multiply every digit of the entered binary number beginning from the last with the powers of 2 correspondingly Step 6:  Repeat the above step...