Skip to main content

How to Find Greatest of Two Numbers in C

 

How to Find Greatest of Two Numbers in C:-


In the C programming language, the greatest of numbers can be identified with the help of the IF-ELSE statement. The user is asked to insert two integers. The numbers inserted are then calculated using a set of programs to get the correct output. It will find the highest number among them using IF-ELSE Statement and start checking which one is larger to display the largest number.


ALGORITHMS:-

Step 1:-  Start
Step 2:-  Insert two integers no1 and no2 from the user with the help of scanf                              statement.
Step 3:- Check if the no1 is bigger in value than no2 using the if statement.
Step4: - If no1 is greater, then print no1 using the print statement, if the case is vice                versa  then check whether no2 is greater than no1 with the help of the else                   if    statement.
Step 5:If no2 is greater than no1, then print no2 using print statement.

CODE: -
#include<stdio.h>
int main()
{
    int num1,num2;
    printf("enter two numbers:");
    scanf("%d\n %d",&num1,&num2);
    if(num1 > num2)
    printf("%d is greatest",num1);
    else if(num2 > num1)
    printf("%d is greatest",num2);
    else
    printf("%d and %d are equal",num1,num2);
    return 0;
}


OUTPUT:-










FOLLOW THIS WEBPAGE FOR MORE NEW PROGRAMS AND CODING SOLUTIONS.

Comments

Popular posts from this blog

HackerRank Tuples Solution in Python

  HackerRank Tuples Solution in Python Task Given an integer,n, and n  space-separated integers as input, create a tuple, t, of those n integers. Then compute and print the result of hash(t). Note:   hash()  is one of the functions in the  __builtins__  module, so it need not be imported. Input Format The first line contains an integer,n, denoting the number of elements in the tuple. The second line contains n space-separated integers describing the elements in tuple t . Output Format Print the result of  hash(t) . Sample Input 0 2 1 2 Sample OUTPUT- 3713081631934410656 n = int(input()) int_list = [int(i) for i in input().split()] int_tuple = tuple(int_list) print(hash(int_tuple))

How to check if the given number is Even or odd-

1. How to check if the given number is Even or odd- We can determine whether a number is even or odd. This can be tested using different methods. The test can be done using simple methods such as testing the number’s divisibility by 2. If the remainder is zero, the number is even. If the remainder is not zero, then the number is odd. The following algorithm describes how a C program can test if a number is even or odd. CODE:- #include <stdio.h> int   main () { int num;//variable declaration printf("Enter any num: ");// take input from user  scanf("%d",&num);// declare input if(num%2==0) { printf("The num %d is even",num); } else { printf("The num %d is odd",num); } return 0; }     ALGORITHM:- Step 1.   Start Step 2 .   Enter a number. Step 3.   If...

Binary to Decimal conversion program

  3. Binary to Decimal conversion program using C language:- The C program converts binary number to decimal number that is equivalent. A decimal number can be attained by multiplying every digit of binary digit with a power of 2 and totaling each multiplication outcome. The power of the integer starts from 0 and counts to n-1 where n is assumed as the overall number of integers in a binary number. Ex:-   ( 101100001 ) 2 =( 353 )10                                                  ALGORITHMS:- Step 1:  Start Step 3:  The user is asked to enter a binary number as an input Step 4:  Store the quotient and remainder of the binary number in the variable rem Step 5:  Multiply every digit of the entered binary number beginning from the last with the powers of 2 correspondingly Step 6:  Repeat the above step...