Skip to main content

How to find the Factor of any number in C

 How to find the Factor of any number in c: -

We will calculate the factors of any numbers using C programming.
The factors of a number are defined as the number we multiply two numbers and get the original number. The factor of a number is a real number that divides the original completely with zero remainders.

ALGORITHM: -

Step 1- Enter the number, to find their factor.

Step 2- Initialise the loop with u=1 to u<=number and follow the following calculation

      (i) check whether the number is divisible with u and u got a result zero.

      (ii) now print the value of u. From this loop, u got all the factors of the number.

Step 3- Stop.

CODE:-

#include<stdio.h>//header file
int main()
{
    int i,num;//variable declaration
    printf("Enter the num to find their factor: ");
    scanf("%d",&num);//to take user input
    for(i=1;i<=num;i++)//for loop for coondition
    {
        if(num%i==0)//check num is perfect divided or not
        {
            printf("factor is %d \n",i);//print value of factor
        }
    }
    return 0;
}

OUTPUT:-












FOLLOW THIS WEBPAGE FOR MORE NEW PROGRAMS AND CODING SOLUTIONS. 

Comments

Popular posts from this blog

HackerRank Tuples Solution in Python

  HackerRank Tuples Solution in Python Task Given an integer,n, and n  space-separated integers as input, create a tuple, t, of those n integers. Then compute and print the result of hash(t). Note:   hash()  is one of the functions in the  __builtins__  module, so it need not be imported. Input Format The first line contains an integer,n, denoting the number of elements in the tuple. The second line contains n space-separated integers describing the elements in tuple t . Output Format Print the result of  hash(t) . Sample Input 0 2 1 2 Sample OUTPUT- 3713081631934410656 n = int(input()) int_list = [int(i) for i in input().split()] int_tuple = tuple(int_list) print(hash(int_tuple))

How to check if the given number is Even or odd-

1. How to check if the given number is Even or odd- We can determine whether a number is even or odd. This can be tested using different methods. The test can be done using simple methods such as testing the number’s divisibility by 2. If the remainder is zero, the number is even. If the remainder is not zero, then the number is odd. The following algorithm describes how a C program can test if a number is even or odd. CODE:- #include <stdio.h> int   main () { int num;//variable declaration printf("Enter any num: ");// take input from user  scanf("%d",&num);// declare input if(num%2==0) { printf("The num %d is even",num); } else { printf("The num %d is odd",num); } return 0; }     ALGORITHM:- Step 1.   Start Step 2 .   Enter a number. Step 3.   If the number is divisible by 2, it is even. Step 4 .   If the number is not divisible by 2, it is odd. Step 5.  Stop EXAMP

Binary to Decimal conversion program

  3. Binary to Decimal conversion program using C language:- The C program converts binary number to decimal number that is equivalent. A decimal number can be attained by multiplying every digit of binary digit with a power of 2 and totaling each multiplication outcome. The power of the integer starts from 0 and counts to n-1 where n is assumed as the overall number of integers in a binary number. Ex:-   ( 101100001 ) 2 =( 353 )10                                                  ALGORITHMS:- Step 1:  Start Step 3:  The user is asked to enter a binary number as an input Step 4:  Store the quotient and remainder of the binary number in the variable rem Step 5:  Multiply every digit of the entered binary number beginning from the last with the powers of 2 correspondingly Step 6:  Repeat the above steps with the quotient obtained until the quotient becomes 0 Step 7:  The sum of the numbers will give the decimal number as a result, print the decimal value. Step 8:   Stop. CODE:-   #includ